After installing the Windows Management Framework, a.k.a PowerShell 2.0, on my test Windows 2008 64 bit Server I fired up the new PowerShell ISE tool and was prompted with this error:
I already knew that PowerShell ISE had a higher dependency on .NET than PowerShell itself which only requires .NET 2.0, however I was curious about the statement in the above message which states:
“If you are running Windows Server 2008, you must use Server Manager to install or configure “.NET Framework 3.5.1”
I knew on my test Windows Server 2008 box that in Server Manager I only had the option to install .NET Framework 3.0, not 3.5.1.
Anyway, I duly installed .NET 3.0 through Server Manager to see what the effect would be on PowerShell ISE.
After the successful installation of .NET 3.0 I fired up the very useful tool ASoft .NET Version Detector 2007 to confirm what versions of of .NET where installed on the machine. (I had already checked in C:\Windows\Microsoft.NET , but ran this tool just to make doubly sure I wasn’t missing something.)
So I had .NET 2.0 SP2 and 3.0, but not 3.5.1. I fired up PowerShell ISE and low and behold it opened.
So my question is does PowerShell ISE require .NET 3.5.1 or only .NET 3.0? Answers on a postcard or comments on the blog please!
Thanks to Aleksandar who pointed out that the answer is in PowerShell help itself and that only .NET 3.0 is required.
So it would appear that the error message in Windows Server 2008 at the top of this post is slightly misleading………